Post Reply
User avatar
Name:NoahJoin In:Feb 21, 2019
CCNA notes-3

Post by Noah » Dec 25, 2018

Show vtp status View the status of the VTP
Wan:
Used to connect to remote sites.
WAN type and encapsulation protocol:
1.Special line: PPP, HDLC, SLIP
2. Circuit Switching: PPP, HDLC, SLIP
3. Packet Exchange: X.25, Frame-Relay, ATM
HDLC:
1.cisco hdlc : An environment that can support multiple protocols, which is implemented by adding the "property" field.
2.standard hdlc: only supports single protocol environment
CISCO routers are encapsulated by cisco HDLC by default on the serial interface.
In practice, cisco hdlc is not compatible with standard hdlc.
PPP:
Support for multiple network layer protocols through NCP can achieve "authentication", "compression", "error detection", "multi-link" through LCP.
PPP authentication method:
1.PAP: Two handshakes, the password is transmitted in clear text.
2.CHAP: Challenge three-way handshake, the password is transmitted using the HASH algorithm, which is stronger than PAP.
Enable HDLC on the interface:
Interface serial 0
Encapsulation HDLC
PPP configuration
Hostname ABC Configure local username
Username 123 password cisco Configure the username and password database to verify each other
Interface serial 0
Encapsulation PPP Enable PPP on the interface
Ppp authentication CHAP chooses to use CHAP for authentication
Debug ppp authentication Debug PPP authentication.
PPP's own password configuration
Interface serial 0
Encapsulation PPP Enable PPP on the interface
Ppp chap hostname abc Send local username in CHAP mode
Ppp chap password cisco sends local passwords in CHAP mode
FRAME-RELAY
1. Connected to a service. 2. Connection based on virtual link
PVC: permanent virtual link
DLCI: Used to identify PVC. Only valid locally.
LMI: Local Management Interface.
BECN: Backward Explicit Congestion Notice
FECN: Forward Explicit Congestion Notice
FRAME-RELAY topology (pvc)
1. full mesh 2. semi-mesh 3. star and spoke
FRAME-RELAY LMI signaling
1. CISCO 2. ANSI 3. Q993A
FRAME-RELAY is a non-broadcast multi-access type network that does not support broadcasting.
Broadcasting is not supported by FRAME-RELAY, which causes the route to be unadvertised. Solution: Copy multiple frames for announcement.
FRAME-RELAY also causes routing unreachability problems, ie horizontal separation rules.
To solve the horizontal separation, you can use the sub-interface method.
FRAME-RELAY address mapping (reverse ARP)
Frame-relay switching
!
Interface Serial0
No ip address
Encapsulation frame-relay
Clockrate 64000
Frame-relay lmi-type ansi
Frame-relay intf-type dce
Frame-relay route 110 interface Serial1 120
!
Interface Serial1
No ip address
Encapsulation frame-relay
Clockrate 64000
Frame-relay lmi-type cisco
Frame-relay intf-type dce
Frame-relay route 120 interface Serial0 110
!
Show frame-relay lmi
Show frame-relay pvc
Show frame-relay map
Basic FRAME-RELAY configuration
Interface s 1
Encapsulation frame-relay
Ip add 10.1.1.1 255.255.255.0
Configuration using point-to-point subinterfaces
Interface s 1
No ip add
Encapsulation frame-relay
No shut
Interface s 1.??? point-to-point Enables a peer-to-peer subinterface. ??? is the interface number.
Ip add 10.1.1.1 255.255.255.0 Configure ip for the subinterface
Frame-relay interface-dlci ??? Assign a specific PVC to this subinterface. ??? is the PVC number.
Configuration with multipoint subinterface
Interface Serial1
No ip address
Encapsulation frame-relay
!
Interface Serial1.1 multipoint
Ip address 10.1.1.1 255.255.255.0
Frame-relay map ip 10.1.1.2 110 broadcast Perform manual static mapping
Private IP address:
A: 10.0.0.0/8
B: 172.16.0.0/16 -- 172.31.0.0/16
C: 192.168.0.0/24 -- 192.168.255.0/24
Hosts with private IP addresses cannot directly access the public network (Internet)
The private IP is not in the routing table of the public network router.
Three types of NAT:
1. Static NAT 2. Dynamic NAT 3. PAT
Static NAT configuration
B(config)#inte s 0
B(config-if)#ip nat inside Configure S0 interface as inside network
B(config)#inte s 1
B(config-if)#ip nat outside Configure the S1 interface as the outside network
Translate an internal source address 192.168.1.10 into an external IP of 1.1.1.1
B(config)#ip nat inside source static 192.168.1.10 1.1.1.1
Dynamic NAT configuration
B(config)#inte s 0
B(config-if)#ip nat inside Configure S0 interface as inside network
B(config)#inte s 1
B(config-if)#ip nat outside Configure the S1 interface as the outside network
Specifies that those hosts can perform NAT
B(config)#access-list 1 permit any
Specify the idle IP of the address pool
B(config)#ip nat pool abc 1.1.1.1 1.1.1.30 prefix-length 24
Translate the host IP of list 1 to the free IP in pool abc
B(config)#ip nat inside source list 1 pool abc
B#show ip nat translations View translation relationship table
PAT configuration
B(config)#inte s 0
B(config-if)#ip nat inside Configure S0 interface as inside network
B(config)#inte s 1
B(config-if)#ip nat outside Configure the S1 interface as the outside network
Specifies that those hosts can perform NAT
B(config)#access-list 1 permit any
Specify the idle IP of the address pool
B(config)#ip nat pool abc 1.1.1.1 1.1.1.1 prefix-length 8
Translate list 1 host IP to pool abc free IP
B(config)#ip nat inside source list 1 pool abc overload
How to make PAT configuration commands when the interface address is unknown
B(config)#ip nat inside source list 1 interface serial 1 overload
1. Configure the ISDN switch type and choose according to the regionality.
R14(config)#isdn switch-type basic-net3
2. Set the dialed number
R14(config)#interface bri 0
R14(config-if)#dialer string 016300
3. Set user password or authentication protocol
R14(config)#interface bri 0
R14(config-if)#encapsulation ppp
R14(config-if)#ppp chap password 16300
R14(config-if)#ppp chap hostname 16300
4. Configure the IP protocol
R14(config)#interface bri 0
R14(config-if)#ip address negotiated
5. Configure a static default route to indicate which interface to send the packet to when it arrives at the unknown network.
R14(config)#ip route 0.0.0.0 0.0.0.0 bri 0
6. Set when to dial the number
R14(config)#access-list 1 permit any
R14(config)#dialer-list 9 protocol ip list 1
R14(config)#interface bri 0
R14(config-if)#dialer-group 9
7. When to disconnect
R14(config-if)#dialer idle-timeout 60
R14#debug isdn events
R14#show isdn active
Reply

Post Reply